Author Topic: 2013 SEF300 TPS connector ???  (Read 97 times)

dhally

  • Intermediate
  • ***
  • Posts: 112
    • View Profile
    • Email
2013 SEF300 TPS connector ???
« on: August 22, 2020, 12:11:04 PM »
I replaced my fan relay (thanks forum!) and after reassembly the bike ran rough and would hardly idle. After taking the tank off and on several times, finally isolated the problem - the TPS electrical connect had come off.  The tab on the TPS itself is partially broken off, so the connector no longer clicks into place. Apparently installing the tank pushes on the wiring enough to unplug it (which is good otherwise I would have found out on the trail...).


I managed to get a small zip tie around the connection but that is temporary. Now the big problem - I don't see a part number for the TPS itself, just the whole throttle body. On the 2013 model the throttle body is Magneti Marelli.


Anybody have ideas on how to fix this? If I need to replace the TPS itself, where would I start looking for one? I can't believe I need to replace the entire injector.  I guess I could splice in a second connector and then epoxy the original one in place.



2013 SE-300i-R
Husqvarna 701E

Southeast Washington state

JL4049

  • Novice
  • *
  • Posts: 17
    • View Profile
    • Email
Re: 2013 SEF300 TPS connector ???
« Reply #1 on: August 23, 2020, 03:37:40 PM »
Your idea of splicing in a new connector and epoxying up the current plug is probably the cheapest, easiest option? I would think that going that route is at least as durable and probably more water tight than the factory set up. Definitely worth a try.

Trackback

  • Novice
  • *
  • Posts: 30
    • View Profile
Re: 2013 SEF300 TPS connector ???
« Reply #2 on: August 23, 2020, 11:10:42 PM »
Go on internet you can buy the part
Not sure there may be a number on it
Itís used on other bikes
eBay the number and name,  I brought them in the past
About £20