Author Topic: power valve question  (Read 164 times)

wvernon

  • Novice
  • *
  • Posts: 2
    • View Profile
power valve question
« on: December 31, 2020, 07:03:00 PM »
I recently bought a 2018 sherco 250 se and the power valve doesn't seem to be working and it doesn't have much top end power. it cycles the electric motor when you first turn the ignition on
then nothing when you flip the mode switch. I tested the switch is good. I put a used power valve control module on it, still does the same thing
I don't see any damage to the wires or plugs everything looks fine. I'm thinking it goes through the ecu as well.
does anyone have a wiring diagram on the power valve curcuit ? or any ideas? id appreciate it thanks. 

Leivan

  • Novice
  • *
  • Posts: 13
    • View Profile
Re: power valve question
« Reply #1 on: December 31, 2020, 08:45:36 PM »
I had an 18 250 with the exact same issue. If the map switch is supposed to make a 7 HP difference (which seems about right), mine made a 1 HP difference. I ran the bike wide open on a road and toggled back and forth between maps. I could feel a slight difference which made me think the map switch worked. There are 2 springs in the powervalve mechanism. They are circular with a leg coming off of each end. One is easy to see under the cover on the right side of the cylinder. The other one is closer to the center of the cylinder and almost impossible to see without some disassembly. Mine was broken and keeping the powervalve from fully opening. It took me a long time to sort it out. Look at a parts catalog to see what Iím talking about. Good luck.

wvernon

  • Novice
  • *
  • Posts: 2
    • View Profile
Re: power valve question
« Reply #2 on: January 01, 2021, 09:18:20 AM »
Thanks Iíll take it Apart and check that.
The video I saw shows a slight movement of the cables when you flip the switch
Itís not doing that but Iím gonna tear into it thanks for your help!