Author Topic: 2019 Sherco 300 SEF plug fouling issues.  (Read 229 times)

ShercoAdam

  • Novice
  • *
  • Posts: 8
    • View Profile
2019 Sherco 300 SEF plug fouling issues.
« on: December 17, 2021, 10:12:31 AM »
So, been having some issues with my 2019 sef 300......

2 weeks ago it wouldn't start, had fuel, air, compression, pulled the plug out and it was black as night. Swapped the plug put and she fired straight up, did 2 days riding on it then went to start it today , no bueno! Same problem, sure enough, the week old plug was fouled again......., swapped it out and fired straight up.

I've not had the bike long so can't vouch for the previous owner, but its done 69 hrs and in good condition - had the valve clearances check recently and was all still mint inside.

Seems to run fine with a new plug for 1 or 2 rides, then won't start and needs a new plug to run again!

I can see a few people have had problems with these bikes eating plugs but once a week is madness, its basically only good as a paper weight if that' the case! Any advice welcomed?

Thanks as always guys

Ad
« Last Edit: December 17, 2021, 11:23:35 AM by ShercoAdam »

LumberJeff

  • Novice
  • *
  • Posts: 27
    • View Profile
    • Email
Re: E10 fuel issue - Sherco 200 set
« Reply #1 on: December 17, 2021, 10:25:52 AM »
Ethanol fuel is the normal thing around most of the U.S. I use Startron Fuel Stabilizer in every tank in all of my non automotive engines. Maybe you need a ECU update to handle the change in fuel?

ShercoAdam

  • Novice
  • *
  • Posts: 8
    • View Profile
Re: E10 fuel issue - Sherco 200 set
« Reply #2 on: December 17, 2021, 10:35:35 AM »
Yeah I had read that it could be something like a remap. Seems weird as mates with KTM's have been running their bikes on whatever they can get with minimal or no issues. Not sure what would cause it to run so rich and foul a plug when everything else seems mint - possibly a coil pack I guess?